Ensuring your Profoto strobes

Having trouble getting your Canon EOS R6 to work with your really expensive Profoto flashes? It may be your shutter mode.

I owe Profoto an apology. I’ve owned the EOS R6 for almost a year now and I love the camera, but for the longest time it simply would not trigger my Profoto B1 and B2 strobes.

I could never figure out why. I assumed I needed to wait for a firmware update to allow the camera to become compatible. The firmware update never came. I made videos about my experiences with the R6, I went to forums asking this question. The R6 isn’t listed as a supported camera on the Profoto website. In fact, Profoto hasn’t updated the firmware for the strobes and Air TTL triggers since November 2019.

I finally hit a breaking point. I needed a strobe that was compatible with my R6’s and I needed it now. So I started to look. I found the Godox AD300 Pro and the Flashpoint XPLOR 300 PRO — they’re the same strobe, just branded differently. Finally, I had a competent strobe that would work with my R6 and it was glorious! I made a video about my experience with the Godox and how disappointed I was with Profoto.

I was wrong!

It wasn’t until I made that Godox video that someone finally asked me a simple question that stopped me in my tracks. A viewer stated that he’d been using his profotos with the R6 and never had any issues.

He also added that “You know if the camera is set to electronic shutter it won’t trigger the strobe.”

First things first, no I didn’t know that. Perhaps I should have, perhaps it’s one of those zillion things most photographers are supposed to know but are afraid to admit in public that they don’t. Moreover, I didn’t think my R6 was set to electronic shutter. I’d never altered that setting.

1 Comment

Leave a Reply

Your email address will not be published. Required fields are marked *

error: